In the Range field of the Exploring tab, I can't enter a number like 1e-7 or 1e5. However, if I enter .00001, UF changes this to 1e-5 and I can edit the number.

Also in the Range field, I can't enter a number like 1.5, as the decimal point is immediately deleted. However, I can enter .5, which UF changes to 0.5, and I can then change the 0 to 1.

This behavior seems limited to the Range field.

In the Range field of the Exploring tab, I can't enter a number like 1e-7 or 1e5. However, if I enter .00001, UF changes this to 1e-5 and I can edit the number. Also in the Range field, I can't enter a number like 1.5, as the decimal point is immediately deleted. However, I can enter .5, which UF changes to 0.5, and I can then change the 0 to 1. This behavior seems limited to the Range field.
 
0
reply

That is odd: I can type both 1e-5 or 1.5. What are your Windows settings for the decimal point (regional settings)?

That is odd: I can type both 1e-5 or 1.5. What are your Windows settings for the decimal point (regional settings)?

Ultra Fractal author

 
0
reply

My decimal settings are standard US, as in the screen shot.
5f9d4082792d0.jpg

My decimal settings are standard US, as in the screen shot. ![5f9d4082792d0.jpg](serve/attachment&path=5f9d4082792d0.jpg)
 
0
reply

The behavior you're describing happens when you type slowly. After the interval set in the Environment tab of the Preferences dialog (by default 0.5 seconds I believe), e.g. the value "1." is replaced by its equivalent "1". If you type faster, you can complete the entire value.

The behavior you're describing happens when you type slowly. After the interval set in the Environment tab of the Preferences dialog (by default 0.5 seconds I believe), e.g. the value "1." is replaced by its equivalent "1". If you type faster, you can complete the entire value.

Ultra Fractal author

 
0
reply

Thank you. I didn't realize that I was entering values so slowly. My delay is set to 1 second. If I enter more quickly, all is well.

Thank you. I didn't realize that I was entering values so slowly. My delay is set to 1 second. If I enter more quickly, all is well.
 
0
reply
53
views
4
replies
2
followers
live preview
Enter at least 10 characters.
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft