I was hoping that switching the center parameter's keys to smooth interpolation would result in a smooth change of direction in a zoom animation. A gentle, natural-looking curve instead of an abrupt turn-on-a-dime. But the interpolation settings don’t seem to have any effect. It's always the same sharp turn halfway through.

Smooth interpolation:

63e0316a5eb09.png
63e0316a5ef21.gif

Linear interpolation:

63e0319a18fe1.png
63e031b295e14.gif

No interpolation:

63e031d0101dc.png
63e0324649255.gif

I was hoping that switching the center parameter's keys to smooth interpolation would result in a smooth change of direction in a zoom animation. A gentle, natural-looking curve instead of an abrupt turn-on-a-dime. But the interpolation settings don’t seem to have any effect. It's always the same sharp turn halfway through. Smooth interpolation: ![63e0316a5eb09.png](serve/attachment&path=63e0316a5eb09.png) ![63e0316a5ef21.gif](serve/attachment&path=63e0316a5ef21.gif) Linear interpolation: ![63e0319a18fe1.png](serve/attachment&path=63e0319a18fe1.png) ![63e031b295e14.gif](serve/attachment&path=63e031b295e14.gif) No interpolation: ![63e031d0101dc.png](serve/attachment&path=63e031d0101dc.png) ![63e0324649255.gif](serve/attachment&path=63e0324649255.gif)

http://www.youtube.com/fractalzooms

 
0
reply

Hi Eric,

I'm sorry for the late response! I find this very curious as well. Can you share the parameter set so I can have a look myself?

Hi Eric, I'm sorry for the late response! I find this very curious as well. Can you share the parameter set so I can have a look myself?

Ultra Fractal author

 
0
reply

Thanks Frederik.

01MiddleKeyCenterSmooth {
fractal:
  title="01 middle key center smooth" width=640 height=180 layers=1
  antialiasing=yes
layer:
  caption="Background" opacity=100
mapping:
  center="-0.5/0@#0SS-1.96961505275/-0.0012317513@#7840NN0.6/-0.03@#15\
  840" magn="1@#0LL1.9791062@#7840LL4@#15840E"
formula:
  maxiter=100 filename="Standard.ufm" entry="Mandelbrot" p_start=0/0
  p_power=2/0 p_bailout=4
inside:
  transfer=none
outside:
  transfer=linear
gradient:
  smooth=yes index=0 color=8716288 index=100 color=16121855 index=200
  color=46591 index=300 color=156
opacity:
  smooth=no index=0 opacity=255
}
02MiddleKeyCenterLinear {
fractal:
  title="02 middle key center linear" width=640 height=180 layers=1
  antialiasing=yes
layer:
  caption="Background" opacity=100
mapping:
  center="-0.5/0@#0SL-1.96961505275/-0.0012317513@#7840LL0.6/-0.03@#15\
  840" magn="1@#0LL1.9791062@#7840LL4@#15840E"
formula:
  maxiter=100 filename="Standard.ufm" entry="Mandelbrot" p_start=0/0
  p_power=2/0 p_bailout=4
inside:
  transfer=none
outside:
  transfer=linear
gradient:
  smooth=yes index=0 color=8716288 index=100 color=16121855 index=200
  color=46591 index=300 color=156
opacity:
  smooth=no index=0 opacity=255
}
03MiddleKeyCenterNone {
fractal:
  title="03 middle key center none" width=640 height=180 layers=1
  antialiasing=yes
layer:
  caption="Background" opacity=100
mapping:
  center="-0.5/0@#0NN-1.96961505275/-0.0012317513@#7840SL0.6/-0.03@#15\
  840" magn="1@#0LL1.9791062@#7840LL4@#15840E"
formula:
  maxiter=100 filename="Standard.ufm" entry="Mandelbrot" p_start=0/0
  p_power=2/0 p_bailout=4
inside:
  transfer=none
outside:
  transfer=linear
gradient:
  smooth=yes index=0 color=8716288 index=100 color=16121855 index=200
  color=46591 index=300 color=156
opacity:
  smooth=no index=0 opacity=255
}
Thanks Frederik. ```` 01MiddleKeyCenterSmooth { fractal: title="01 middle key center smooth" width=640 height=180 layers=1 antialiasing=yes layer: caption="Background" opacity=100 mapping: center="-0.5/0@#0SS-1.96961505275/-0.0012317513@#7840NN0.6/-0.03@#15\ 840" magn="1@#0LL1.9791062@#7840LL4@#15840E" formula: maxiter=100 filename="Standard.ufm" entry="Mandelbrot" p_start=0/0 p_power=2/0 p_bailout=4 inside: transfer=none outside: transfer=linear gradient: smooth=yes index=0 color=8716288 index=100 color=16121855 index=200 color=46591 index=300 color=156 opacity: smooth=no index=0 opacity=255 } ```` ```` 02MiddleKeyCenterLinear { fractal: title="02 middle key center linear" width=640 height=180 layers=1 antialiasing=yes layer: caption="Background" opacity=100 mapping: center="-0.5/0@#0SL-1.96961505275/-0.0012317513@#7840LL0.6/-0.03@#15\ 840" magn="1@#0LL1.9791062@#7840LL4@#15840E" formula: maxiter=100 filename="Standard.ufm" entry="Mandelbrot" p_start=0/0 p_power=2/0 p_bailout=4 inside: transfer=none outside: transfer=linear gradient: smooth=yes index=0 color=8716288 index=100 color=16121855 index=200 color=46591 index=300 color=156 opacity: smooth=no index=0 opacity=255 } ```` ```` 03MiddleKeyCenterNone { fractal: title="03 middle key center none" width=640 height=180 layers=1 antialiasing=yes layer: caption="Background" opacity=100 mapping: center="-0.5/0@#0NN-1.96961505275/-0.0012317513@#7840SL0.6/-0.03@#15\ 840" magn="1@#0LL1.9791062@#7840LL4@#15840E" formula: maxiter=100 filename="Standard.ufm" entry="Mandelbrot" p_start=0/0 p_power=2/0 p_bailout=4 inside: transfer=none outside: transfer=linear gradient: smooth=yes index=0 color=8716288 index=100 color=16121855 index=200 color=46591 index=300 color=156 opacity: smooth=no index=0 opacity=255 } ````

http://www.youtube.com/fractalzooms

 
0
reply

OK, it's been a while so I had to dive into this code. Unfortunately UF does not do a smooth turn on the center like you would expect. The center is special because it is interpolated to give a smooth movement together with the magnification and the code always treats it as having linear interpolation. If you want a smooth turn you'll have to add extra keys around the turn to indicate what you're after. I realize this is not ideal.

There's also a bug in the Timeline tool window: the drop-down box for the curve type on the right has the images in the wrong order. Stepped should be first, then Linear, then Smooth, but the order is reversed. That means that when the interpolation really is smooth, it shows it as stepped and vice versa. I'll fix this in an update but for now, you'll have to turn around those in your mind while working with the Timeline window...

OK, it's been a while so I had to dive into this code. Unfortunately UF does not do a smooth turn on the center like you would expect. The center is special because it is interpolated to give a smooth movement together with the magnification and the code always treats it as having linear interpolation. If you want a smooth turn you'll have to add extra keys around the turn to indicate what you're after. I realize this is not ideal. There's also a bug in the Timeline tool window: the drop-down box for the curve type on the right has the images in the wrong order. Stepped should be first, then Linear, then Smooth, but the order is reversed. That means that when the interpolation really is smooth, it shows it as stepped and vice versa. I'll fix this in an update but for now, you'll have to turn around those in your mind while working with the Timeline window...

Ultra Fractal author

 
0
reply

Thanks Frederik. I wish this were somehow doable but I appreciate the explanation and suggestion. I’ll try adding keys to smooth out the turns.

Thanks Frederik. I wish this were somehow doable but I appreciate the explanation and suggestion. I’ll try adding keys to smooth out the turns.

http://www.youtube.com/fractalzooms

 
0
reply
94
views
4
replies
2
followers
live preview
Enter at least 10 characters.
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft