Hello,

I upgraded to UF 6.04 today and every time I open the explorer window for any parameter I get a huge CPU spike. This happens even if my mouse is nowhere near the window and nothing else is rendering. This takes several seconds and despite having a 12C/24T CPU it drains my computer of resources to an extent that even the playback of windowed Youtube Videos starts to stutter.

Oddly enough, the exploring itself is perfectly smooth and doesn't cause any spikes once the initial spike has passed, but it makes the computer unusable for about 5-10 seconds.

Specs:
Windows 10
Ryzen 9 3900X
32 GB of RAM
Geforce GTX 1070

Let me know if you need any more info, or if I can do anything to help you troubleshoot this.

Best regards,
Phillip

Hello, I upgraded to UF 6.04 today and every time I open the explorer window for any parameter I get a huge CPU spike. This happens even if my mouse is nowhere near the window and nothing else is rendering. This takes several seconds and despite having a 12C/24T CPU it drains my computer of resources to an extent that even the playback of windowed Youtube Videos starts to stutter. Oddly enough, the exploring itself is perfectly smooth and doesn't cause any spikes once the initial spike has passed, but it makes the computer unusable for about 5-10 seconds. Specs: Windows 10 Ryzen 9 3900X 32 GB of RAM Geforce GTX 1070 Let me know if you need any more info, or if I can do anything to help you troubleshoot this. Best regards, Phillip
 
0
reply

Hello,

I know I never really provided anything that would help to troubleshoot this, and I'm sorry for that. But now this might change. By sheer coincidence I just observed something that might shed some light on this problem.

Usually I work with UF in fullscreen mode, so I never noticed this, but when I open the explorer, UF actually recalculates the previews in other windows too. This is usually not a problem because they are fast, but right now I have a few fractlals open where the preview takes 10-15 seconds to render and while that is happening in multiple windows at the same time the performance of my machine nose-dives completely. I attached a screenshot to show the phenomenon in action.

So maybe this is some unintended behavior that might have an easy fix, only calculate the preview for the active window (the one where the explorer was opened). smile

Best regards,
Phillip61f965c53eabe.png

Hello, I know I never really provided anything that would help to troubleshoot this, and I'm sorry for that. But now this might change. By sheer coincidence I just observed something that might shed some light on this problem. Usually I work with UF in fullscreen mode, so I never noticed this, but when I open the explorer, UF actually recalculates the previews in other windows too. This is usually not a problem because they are fast, but right now I have a few fractlals open where the preview takes 10-15 seconds to render and while that is happening in multiple windows at the same time the performance of my machine nose-dives completely. I attached a screenshot to show the phenomenon in action. So maybe this is some unintended behavior that might have an easy fix, only calculate the preview for the active window (the one where the explorer was opened). :) Best regards, Phillip![61f965c53eabe.png](serve/attachment&path=61f965c53eabe.png)
 
0
reply

That is very interesting. I think it would be much better if the "mode" only applies to the current fractal window, and I'll look into that.

That is very interesting. I think it would be much better if the "mode" only applies to the current fractal window, and I'll look into that.

Ultra Fractal author

 
0
reply
70
views
2
replies
2
followers
live preview
Enter at least 10 characters.
WARNING: You mentioned %MENTIONS%, but they cannot see this message and will not be notified
Saving...
Saved
All posts under this topic will be deleted ?
Pending draft ... Click to resume editing
Discard draft